All-Inkl – Probleme mit den Permalinks und der .htaccess

Update 28. Mai 2013!

Inzwischen scheint die u.a. Angabe in der .htaccess Probleme zu bereiten: HTTP-Fehler beim Bildupload. Sollten also beim Media-Upload o.ä. Fehlermeldungen auftauchen, bitte direkt den freundlichen Support von all-inkl.com kontaktieren, ggf. sind Änderungen/Korrekturen der Servereinstellungen erforderlich!

Wichtig ist auch, nach der Umstellung den Browser-Cache zu löschen (Firefox ist da manchmal schwierig). Auch ein Test mit einem anderen Browser ist sinnvoll :)


Artikel vom 1.4.2010

Eine neue Webseite ist bei https://all-inkl.com gehostet. Bei der Umstellung der WordPress-Permalinks erhielt ich folgende Fehlermeldung:

Wenn deine .htaccess-Datei beschreibbar wäre, könnte WordPress sie automatisch bearbeiten. Das ist nicht der Fall. Darum findest du hier die mod_rewrite-Regeln, die du manuell in deine .htaccess-Datei einfügen musst. Klick in das Feld und verwende Strg+A, um alles auszuwählen.

Die Lösung ist einfach. In das Verzeichnis wp-admin gehört eine .htaccess-Datei mit folgendem Inhalt:

AddHandler php5-cgi .php

Falls diese Datei noch nicht vorhanden ist, bitte mit einem Texteditor anlegen (und auch .htaccess nennen – nicht .htcaccess.txt).

Dann klappt auch das automatische Update.

Weitere Sicherheitstipps findet man unter wp-admin durch .htaccess schützen und Sicherheit in WordPress: 10 Schritte zum Schutz des Admin-Bereichs .

1 Stern2 Sterne3 Sterne4 Sterne5 Sterne (5 votes, average: 4,80 out of 5)
Loading...

Weitere Artikel aus dieser Kategorie


29 Kommentare zu diesem Artikel bisher »

Kommentare zu »All-Inkl – Probleme mit den Permalinks und der .htaccess«

  1. Vielen Dank!
    Hat mir wirklich geholfen, da ich WordPress einfach nicht dazu überreden konnte die .htaccess selbst zu ändern.

    Greetz

  2. Cool, danke
    hat mir geholfen

  3. Vielen Dank für die Anleitung hat mir sehr weitergeholfen. Habe da vorher schon lange herumprobiert.

  4. Dankedankedanke!

    Ich hab lange gedacht, ich wär zu doof für Permalinks und .htaccess

  5. Vielen Dank!!! Ich habe echt lange gesucht und hier endlich die Lösung gefunden! Ich wäre fast an den Permalinks verzeifelt.

  6. Vielen Dank. Ich war echt am verzweifeln, überall hat es immer ohne Probleme geklappt nur nicht bei All-inkl. Jetzt geht es wie es soll.

  7. Ich habe dieses Problem auch, konnte es aber damit nicht lösen.
    Das gesamt WP-dashboard ist voll mit Fehlermeldungen. Entferne ich die Datei wieder, ist es wie vorher.

  8. Vielen Dank, bin gerade im Aufbau meiner Seite und habe einige Zeit mit den Permalinks verbracht. Dank deiner Anleitung funktioniert es jetzt, super. Danke!

  9. Vielen Vielen Dank für diesen Tipp! Bin schon seit Tagen am rumprobieren und keine andere Anleitung konnte mir weiterhelfen. Mit dieser kurzen Erklärung war alles in 2 Minuten erledigt. Merci!

  10. dito!

    vielen dank für den tip.

  11. ich habe bis dato irr viele Kunden bei all-inkl.com
    und noch niemals trat dieses Problem auf.

    1. was ist denn da für ein HostingPaket im Einsatz
    2. php5 muss ich dort seit langem nicht mehr extra angeben

    3. kann ich via ftp der htaccess immer genügend Rechte geben grad bei all-inkl.com

  12. Ich habe beim All-inkl.com-Kundenservice folgende Frage gestellt:

    Ist es korrekt, dass in die .htaccess die Angabe AddType application/x-httpd-php php php5 php4 php3 html htm gehört, damit php ausgeführt wird (html mit include php)
    und AddHandler php5-cgi .php damit WordPress (Permalinks, Autoupdate) funktioniert? Oder welche Angaben sind in welchen Fällen erforderlich?

    Die Antwort:

    Die Angaben die Sie gemacht haben sind so korrekt.

    AddType application/x-httpd-php php php5 php4 php3 html htm:
    Um diverse Dateiendungen ( Bsp. php3 ) durch PHP verarbeiten zu lassen.

    AddHandler php5-cgi .php:
    Um den CGI-Mode zu aktivieren, damit div. Funktionen ( Bsp: system() oder exec() )
    freigeschalten sind, damit beispielsweise Updates durchführen können.

  13. War sehr lange am verzweifeln, jetzt geht’s – kleiner Tipp mit großer Wirkung kann man hier wohl ganz sicher sagen. Danke

  14. …hmm.. also die permalinks funtkioeren jetzt allerdings habe ich jetzt einige fehlermeldungen im backend-kopg…

    z.B.
    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/w0061028/wordpress/wp-content/plugins/quick-shop/quickshop_class.php:29) in /www/htdocs/w0061028/wordpress/wp-includes/functions.php on line 861

    quickshop ist ein plugin und kommt aus irgend einem grund nicht mit der htaccess klar.. irgend ne idee?

    danke und gruß,
    jochen

  15. Achte darauf, dass keinerlei Leerzeichen vor der ersten Zeile Code und nach der letzten Zeile Code vorhanden ist, gilt für die .htaccess und alle php-Dateien.

  16. Vielen Dank!! alleine der kleine Zusatz das „.txt“ raúszunehmen hat mich gerettet!!! Danke!

  17. Vielen Dank. Hab mich fast zu Tode gesucht. :D

  18. Besten Dank! Die Zweifel begannen, ordentlich an mir zu nagen… :)

  19. perfekt! endlich hab ich die permalinks, die ich will. danke

  20. Geil, Danke! Funktioniert Einwandfrei!

  21. DANKE!!!! Ich war schon am verzweifeln!

  22. Super! Heißesten Dank! Dieser Tipp war sehr (!!) hilfreich!

  23. Dankeschön, Klaus, für diesen Beitrag.
    Nachdem ich letzte Woche mehrere Versuche unternommen hatte, die Permalinks auf „Beitragsname“ umzustellen — es kam anschließend immer zu Fehlern bei der Anzeige der Inhalte –, war ich schon kurz davor, die suchmaschinen-untaugliche Standardform der Permalinks beizubehalten.

    Heute setzte ich mich dann doch noch einmal hin (und zwar mit geballten Fäusten…), um dem schurkischen Treiben ein Ende zu bereiten, aber wie sich herausstellte, war meine mentale Einstimmung auf einen Bossgegner übertrieben, denn schnell war dein Beitrag bei Tantchen Google gefunden und die fehlende .htaccess im „wp-admin“-Verzeichnis (im Root lag bereits eine) hinzugefügt.

    Vielen Dank fürs Teilen!

  24. Ich verzweifle trotz allem. Bin auch bei Allinkl und irgendwie funktioniert das Setzen der Permalinks nicht. Hab schon alles mögliche probiert, kenne mich aber leider nicht wirklich aus.
    Was ist falsch?
    Hier der Inhalt meiner htaccess (die unter wp-admin auf dem FTP-Server liegt und nachdem ich schon alle möglichen Kombinationen ausprobiert habe):

    AddHandler php5-cgi .php
    AddType application/x-httpd-php php php5 php4 php3 html htm

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

  25. Super! Der Tipp mit keinerlei Leerzeichen in der Datei hat mich gerettet! VIelen Dank

  26. Besten Dank, damit auch für mich ein Problem in meinem Testblog gelöst, wo sich der Cache nicht direkt über das Plugin einschalten ließ – mit der „Anleitung“ ging es :))

  27. Bei mir bleibt dennoch alles unverändert, obwohl ich die .htacess genau so hinzugefügt habe.
    In einer zweiten wp-Installation auf dem gleichen Webspace, welche vollständig funktioniert, existiert nicht eine einzige .htacess.

  28. @Roman Die Datei heißt .htaccess, und probiere ggf.: AddHandler php54-cgi .php

  29. ich habe schon alles versucht. in dupilcator den admin account belassen wie es ist, oder ein neues anlegen spielt keine rolle, kein anmelden möglich. ich habe das Passwort auch per phpmyadmin schon geändert alles hilft nicht. ich komme nicht mehr rein hat jemand eine Idee?

Kommentieren

Erlaubtes XHTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>